Warning in spite of correct provider name

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Warning in spite of correct provider name

suchi
Even though the provider mentioned in my persistence.xml is as follows:
<provider>org.hibernate.jpa.HibernatePersistenceProvider</provider>

I see the following warning while trying to create the EntityManagerFactory:

WARN org.hibernate.ejb.HibernatePersistence  - HHH015016: Encountered a deprecated javax.persistence.spi.PersistenceProvider [org.hibernate.ejb.HibernatePersistence]; use [org.hibernate.jpa.HibernatePersistenceProvider] instead.

I will appreciate inputs as to why so?

Thanks,
Suchi